algoritmo "semnome"
// Função : transformar valores de temperatura
// Autor : Filipe Carmona
// Data : 27/02/2010
var
z,tipo:inteiro
temp,result:real
inicio
repita
  repita
    escreval ("conversor de temperaturas 1.0")
    escreval ("selecione o tipo de conversão")
    escreval ("(1) celsius - farenheit")
    escreval ("(2) celsius - kelvin")
    escreval ("(3) farenheit - celsius")
    escreval ("(4) farenheit - kelvin")
    escreval ("(5) kelvin - celsius")
    escreval ("(6) kelvin - farenheit")
    leia (tipo)
    Se (tipo <1) ou (tipo >6) entao
      limpatela
      escreval ("digite uma das opções válidas (de 1 a 6)")
    fimse
  ate (tipo >=1) e (tipo <=6)
  limpatela
  escreval ("agora digite o valor a ser convertido")
  leia(temp)
  Se tipo = 1 entao
    result <- (temp*1.8) + 32
  fimse
  Se tipo = 2 entao
    result <- temp+273.15
  fimse
  Se tipo = 3 entao
    result <- (temp - 32)/1.8
  fimse
  Se tipo = 4 entao
    result <- (temp + 459.67)/1.8
  fimse
  Se tipo = 5 entao
    result <- temp - 273.15
  fimse
  Se tipo = 6 entao
    result <- (temp*1.8) -459.67
  fimse
  escreval ("o resultado é", result)
  escreval ("")
  repita
    escreval ("deseja fazer outra conversão?")
    escreval ("1 - sim")
    escreval ("2 - nao")
    leia (z)
    se (Z>2) ou (Z<1) entao
      escreval ("Opção Inexistente")
    fimse
  ate (Z>0) e (Z<3)
Ate Z = 2
fimalgoritmo

Comentários