algoritmo "Exercício 1"
// Função : Gerar a sequência Fibonacci
// Autor : Luis Carlos Farias
// Data : 8/11/2009
// Seção de Declarações 
var
anterior, atual, proximo : INTEIRO
inicio
// Seção de Comandos 
escreval (" 1") // Apresenta o que está entre ("")
anterior <- 0   //Valor anterior
atual <- 1 //Valor atual
proximo <- 1 //Proximo valor
enquanto atual < 89 faca //Condicional enquanto/faça
proximo <- anterior + atual //Expressão soma de anterior + atual = proximo
escreval (proximo) //Apresenta os valores de proximo
anterior <- atual //Variavel acumuladora
atual <- proximo //Variavel acumuladora
FIMENQUANTO
fimalgoritmo

Comentários