Todos nós sabemos criar e seguir algoritmos

  • Todos nós sabemos criar e seguir algoritmos

  • Como ir de casa até o trabalho?

  • Como fazer um bife à milaneza?

  • Como trocar o pneu do carro?

Como fazer para que as três rãs que estão em quatro casas nas seguintes posições,

  • Como fazer para que as três rãs que estão em quatro casas nas seguintes posições,

  • terminem assim?

Somente pular para a casa da frente ou de trás se ela estiver vazia.

  • Somente pular para a casa da frente ou de trás se ela estiver vazia.

  • Pular a rã vizinha se for parar em uma casa vazia.

  • Este algoritmo serve para ordenar dados, e é muito utilizado em computação.

?

  • ?

TRAVESSIA DO RIO: Como fazer para que um barqueiro atravesse o rio com suas cargas cuidando das seguintes regras:

  • TRAVESSIA DO RIO: Como fazer para que um barqueiro atravesse o rio com suas cargas cuidando das seguintes regras:

    • O barqueiro somente pode levar uma carga por vez
    • O lobo come a ovelha se deixados sozinhos
    • A ovelha come o repolho se deixados sozinhos

?

  • ?

USAR UMA CALCULADORA: como ensinar uma criança (6 anos) a usar uma calculadora para realizar as seguintes operações?

  • USAR UMA CALCULADORA: como ensinar uma criança (6 anos) a usar uma calculadora para realizar as seguintes operações?

    • 2 + 5
    • 3 + 1
    • 5 – 2

?

  • ?

CÁLCULO DA ÁREA DE UMA MESA: como ensinar alguém a calcular a área de uma mesa?

  • CÁLCULO DA ÁREA DE UMA MESA: como ensinar alguém a calcular a área de uma mesa?

?

  • ?

Cada pessoa possui sua forma de representar passos

  • Cada pessoa possui sua forma de representar passos

  • Em computação precisamos organizar essa especificação de forma que o computador entenda!

algoritmo “nome_algoritmo”

  • algoritmo “nome_algoritmo”

  • var

  • nome_variaveis : tipo;

  • inicio

  • comandos;

  • fimalgoritmo

Calcular a área de uma mesa retangular

  • Calcular a área de uma mesa retangular

  • algoritmo “area”

  • var

  • comprimento, largura, area: inteiro

  • inicio

  • leia(comprimento)

  • leia(largura)

  • área <- comprimento * largura

  • escreva(”Área igual a ”, area)

  • Fimalgoritmo

  • Observe as palavras em negrito, são as palavras chaves da linguagem.

Declaração de variáveis:

  • Declaração de variáveis:

  • var

  • nome_variaveis : tipo;

  • Nome_variáveis é uma lista de identificadores separados por vírgulas

  • Tipo é um nome de tipo de dado

  • Exe.: ano : inteiro

Principais comandos

  • Principais comandos

  • Entrada de Dados (digitação teclado)

  • leia(nome_variavel)

  • Exe.: leia(ano)

  • Saída de Dados (exibe no monitor)

  • escreva(nome_variavel)

  • Exe.: escreva(ano)

Principais comandos

  • Principais comandos

  • Atribuição (expressões)

  • Nome_variavel <- expressão

  • idade <- 2008 - ano

Calcular a área de uma mesa retangular

  • Calcular a área de uma mesa retangular

  • algoritmo “area”

  • var

  • comprimento, largura, area: inteiro

  • inicio

  • leia(comprimento)

  • leia(largura)

  • área <- comprimento * largura

  • escreva(”Área igual a ”, area)

  • fimalgoritmo

  • Observe as palavras em negrito, são as palavras chaves da linguagem.

Calcular o preço de uma passagem de ônibus

  • Calcular o preço de uma passagem de ônibus

  • algoritmo “passagem”

  • var

  • idade, preco: inteiro

  • inicio

  • leia(idade)

  • leia(preço)

  • se idade < 65 então

  • escreva(“Preço é ”, preco)

  • senão

  • escreva(“Grátis”)

  • fimse

  • fimalgoritmo

Comentários